Project

General

Profile

Bug #2051

Не собирается в openSUSE

Added by fox almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Plugins: Aggregator
Target version:
Start date:
01/16/2018
Due date:
% Done:

100%

Estimated time:
3.00 h
Reported in:
master

Description

LeechCraft более не собирается после обновления Wt до 4.0.2 и Boost до 1.66. Основные ошибки выглядят так:

…
[  391s] In file included from /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/aggregatorapp.h:34:0,
[  391s]                  from /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/servermanager.cpp:38:
[  391s] /usr/include/Wt/WModelIndex:12:2: warning: #warning "The use of header files without .h is deprecated since Wt 4.0.0, please use WModelIndex.h instead" [-Wcpp]
[  391s]  #warning "The use of header files without .h is deprecated since Wt 4.0.0, please use WModelIndex.h instead" 
[  391s]   ^~~~~~~
[  392s] In file included from /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/servermanager.cpp:38:0:
[  392s] /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/aggregatorapp.h:74:14: error: 'UserRole' is not a member of 'Wt'
…
[  394s] In file included from /usr/include/Wt/cpp17/any.hpp:78:0,
[  394s]                  from /usr/include/Wt/WAny.h:11,
[  394s]                  from /usr/include/Wt/WModelIndex.h:15,
[  394s]                  from /usr/include/Wt/WAbstractItemModel.h:11,
[  394s]                  from /usr/include/Wt/WAbstractProxyModel.h:10,
[  394s]                  from /usr/include/Wt/WSortFilterProxyModel.h:10,
[  394s]                  from /usr/include/Wt/WSortFilterProxyModel:17,
[  394s]                  from /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/readchannelsfilter.h:32,
[  394s]                  from /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/readchannelsfilter.cpp:30:
[  394s] /usr/include/Wt/cpp17/any/any.hpp:410:18: note:   'linb::any_cast'
[  394s]  inline ValueType any_cast(any&& operand)
[  394s]                   ^~~~~~~~
[  394s] /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/readchannelsfilter.cpp:63:29: error: expected primary-expression before 'int'
[  394s]       return boost::any_cast<int> (data) > 0;
[  394s]                              ^~~
[  394s] /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/readchannelsfilter.cpp:63:29: error: expected ';' before 'int'
[  394s] /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70~git20180113T005931/src/plugins/aggregator/plugins/webaccess/readchannelsfilter.cpp:63:32: error: expected unqualified-id before '>' token
[  394s]       return boost::any_cast<int> (data) > 0;
[  394s]                                 ^
[  395s] make[2]: *** [plugins/aggregator/plugins/webaccess/CMakeFiles/leechcraft_aggregator_webaccess.dir/build.make:143: plugins/aggregator/plugins/webaccess/CMakeFiles/leechcraft_aggregator_webaccess.dir/readchannelsfilter.cpp.o] Error 1

Теперь новые установки невозможны, а на протухающие установленные версии долго рассчитывать нельзя: GNU/Linux - не место для bitrot'а.


Files

#1

Updated by 0xd34df00d almost 3 years ago

  • Target version set to 0.6.75
  • Assignee set to 0xd34df00d
  • Status changed from New to Assigned
  • Category set to Plugins: Aggregator
#2

Updated by 0xd34df00d almost 3 years ago

  • Estimated time set to 3.00 h
  • % Done changed from 0 to 100
  • Status changed from Assigned to Closed

Говорят, починилось уже с недельку как в опенсусе-билдах. У меня оно всё равно не собирается, но по другой причине.

Also available in: Atom PDF