Project

General

Profile

Bug #2018

[Xoox] Certificate errors aren't shown

Added by krigstask almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Plugins: Azoth
Target version:
Start date:
10/30/2016
Due date:
% Done:

100%

Estimated time:
10.00 h
Reported in:
master

Description

After updating from git/master (I think that was on Oct 27) my Azoth cannot connect to servers (I have accounts on gentoo.ru and jabber.se, both worked fine before that update). Pidgin continues to work fine, so there's nothing wrong with network or servers themselves.
Console log:

→→→→→→ [14:50:10.649] →→→→→→
?xml version='1.0'?><stream:stream to='gentoo.ru' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'

←←←←←← [14:50:10.666] ←←←←←←
?xml version='1.0'?><stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' id='312731050' from='gentoo.ru' version='1.0' xml:lang='ru'><stream:features><starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/><compression xmlns='http://jabber.org/features/compress'><method>zlib</method></compression><mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'><mechanism>PLAIN</mechanism></mechanisms><c xmlns='http://jabber.org/protocol/caps' hash='sha-1' node='http://www.process-one.net/en/ejabberd/' ver='kxldlsZuzEZzrZKi50X/YdUuN44='/></stream:features

→→→→→→ [14:50:10.666] →→→→→→
  <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>

←←←←←← [14:50:10.683] ←←←←←←
  <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>

Also available in: Atom PDF