Project

General

Profile

Feature #674

Save scrobbling queue

Added by 0xd34df00d over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Plugins: LastFMScrobble
Target version:
Start date:
04/25/2012
Due date:
% Done:

100%

Estimated time:
4.00 h

Description

If a track has failed to be scrobbled, it should be saved to be scrobbled later.
According to official documentation ( http://www.audioscrobbler.net/development/protocol/ ):

Clients should be able to cope with long (multiples hours) downtime from the server. This may be caused by either server failure or a lack of network connectivity by the client (e.g. a portable system such as a laptop with only brief connectivity).

Seems like the best way to do this is to use Track::toDomElement() to save tracks and to use the Track (QDomElement) ctor to restore them later on.

Keep in mind that the queue must survive between LC's restarts.

#1

Updated by Magog over 8 years ago

I've tried but I can't to do this. Please, remove me from "Assignee"

#2

Updated by 0xd34df00d over 8 years ago

Nope you can.

#3

Updated by Magog over 8 years ago

No. I tried. But I cann't:-(

#4

Updated by 0xd34df00d over 8 years ago

  • Status changed from Assigned to Closed
  • Assignee changed from Magog to 0xd34df00d
  • % Done changed from 0 to 100
  • Estimated time set to 4.00 h

Also available in: Atom PDF