Project

General

Profile

Bug #1895

Обнуление настройки смайлпапка

Added by DA over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Plugins: Azoth
Target version:
Start date:
03/10/2015
Due date:
% Done:

100%

Estimated time:
2.00 h
Reported in:
master

Description

При удалении плагина смайлов, обнуляются настройки.

STR:
Ставим плагин смайлов.
Ставим пакет смайлов.
Выбираем набор в настройках.
Удаляем плагин смайлов.
Ставим плагин смайлов.
Проверяем настройки.

Expected result:
Когда-то выбранный набор.

Actual result:
Значение по умолчанию.

System information:
LeechCraft 0.6.70-2806-gaabf218
Built with Qt 4.8.6, running with Qt 4.8.6
Running on: openSUSE 13.2 (Harlequin) (x86_64) x86_64 3.16.7-7-desktop #1 SMP PREEMPT Wed Dec 17 18:00:44 UTC 2014 (762f27a)

#1

Updated by 0xd34df00d over 5 years ago

А как ему ещё себя вести? Он же настройки смайлпака выбирает из списка текущих, это by design так.

#2

Updated by DA over 5 years ago

Другие настройки не обнуляются при таких манипуляциях. Хранить настройку в плагине смайлов, хз.

#3

Updated by 0xd34df00d over 5 years ago

Другие — это какие?

#4

Updated by DA over 5 years ago

Никакие другие, единственная настройка, которую надо перевыставлять после твоих `-P`.

#5

Updated by DA over 3 years ago

Relevant.

#6

Updated by 0xd34df00d over 3 years ago

  • Target version set to 0.6.75
  • Status changed from New to Assigned
#7

Updated by 0xd34df00d over 3 years ago

  • Estimated time set to 2.00 h
#8

Updated by 0xd34df00d over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved
#9

Updated by 0xd34df00d over 3 years ago

  • Status changed from Resolved to Closed

Будем считать, что норм.

Also available in: Atom PDF