Project

General

Profile

Bug #1826

SEGV

Added by Mellon almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Plugins: SB2
Target version:
Start date:
12/05/2014
Due date:
% Done:

100%

Estimated time:
3.00 h
Reported in:
master

Description

 % tail -n3 .leechcraft/*.log 
==> .leechcraft/critical.log <==
[04.12.2014 00:16:44.271] [0x7fc07c00b3c0] [5657] JSonScanner::yylex - unknown char, returning -1 

==> .leechcraft/debug.log <==
[05.12.2014 16:46:23.408] [0x7f29afa86c40] [1491] virtual QIcon LeechCraft::IconThemeEngine::GetIcon(const QString&, const QString&) no icon for "view-refresh-periodically" "" "oxygen" ("/home/user/.leechcraft/icons", "/home/user/.kde4/share/icons/", "/usr/share/icons/", ":/icons") 
[05.12.2014 16:46:46.444] [0x7f29afa86c40] [1494] LeechCraft::SB2::QuarkManager::QuarkManager(LeechCraft::QuarkComponent_ptr, LeechCraft::SB2::ViewManager*, ICoreProxy_ptr) adding  QUrl( "file:///usr/share/leechcraft/qml/advancednotifications/ANQuark.qml" )  
[05.12.2014 16:46:46.457] [0x7f29afa86c40] [1495] LeechCraft::SB2::QuarkManager::QuarkManager(LeechCraft::QuarkComponent_ptr, LeechCraft::SB2::ViewManager*, ICoreProxy_ptr) adding  QUrl( "file:///usr/share/leechcraft/qml/advancednotifications/ANQuark.qml" )  

==> .leechcraft/fatal.log <==
[05.12.2014 16:16:27.469] [0x7f4b6dfbcc40] [1682] ASSERT: "last >= first" in file /var/tmp/portage/dev-qt/qtcore-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/corelib/kernel/qabstractitemmodel.cpp, line 2413
[05.12.2014 16:31:00.465] [0x7fbb1f796c40] [1735] ASSERT: "last >= first" in file /var/tmp/portage/dev-qt/qtcore-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/corelib/kernel/qabstractitemmodel.cpp, line 2413
[05.12.2014 16:46:46.457] [0x7f29afa86c40] [1496] ASSERT: "last >= first" in file /var/tmp/portage/dev-qt/qtcore-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/corelib/kernel/qabstractitemmodel.cpp, line 2413

==> .leechcraft/warning.log <==
[05.12.2014 16:45:57.250] [0x7f29afa86c40] [1485] void LeechCraft::DockToolbarManager::AddDock(QDockWidget*, Qt::DockWidgetArea) double-adding QDockWidget(0x7f29aff2eef0) "Azoth" 
[05.12.2014 16:46:23.408] [0x7f29afa86c40] [1492] void LeechCraft::DockToolbarManager::AddDock(QDockWidget*, Qt::DockWidgetArea) double-adding QDockWidget(0x7f29aff2eef0) "Azoth" 
[05.12.2014 16:46:26.296] [0x7f29afa86c40] [1493] void LeechCraft::DockToolbarManager::AddDock(QDockWidget*, Qt::DockWidgetArea) double-adding QDockWidget(0x7f29aff2eef0) "Azoth" 

STR:
Нажать на "Добавить кварк" в насройках SB2

Expected result:

Actual result:

System information:
LeechCraft 0.6.70-1783-g5a151f5
Built with Qt 4.8.6, running with Qt 4.8.6
Running on: Gentoo/Linux x86_64 3.16.3-gentoo #1 SMP PREEMPT Sun Oct 5 05:12:41 MSK 2014


Files

lc_crash_14_12_05-16_49_15.log (86.5 KB) lc_crash_14_12_05-16_49_15.log Mellon, 12/05/2014 04:58 PM
#1

Updated by 0xd34df00d almost 6 years ago

  • Estimated time set to 3.00 h
  • Target version set to 0.6.75
  • Status changed from New to Assigned

Can't reproduce, но это объясняется дебаговым билдом у тебя, там лишние проверки, которые ничему не вредят, но ассертятся.

#2

Updated by 0xd34df00d almost 6 years ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved
#3

Updated by Mellon almost 6 years ago

  • Status changed from Resolved to Closed

Исправлено. Благодарю.

Also available in: Atom PDF