Project

General

Profile

Feature #1772

Игнорирование добавления некоррекного аргумента после /openurl index | range | "last" | "*"

Added by Mellon almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Plugins: Azoth
Target version:
Start date:
10/23/2014
Due date:
% Done:

100%

Estimated time:
4.00 h

Description

В общем, иххо, следует выдавать ошибку при команде
/openurl index | range | "last" | "*" "random shit"
ибо, скорее всего, опечатка.
то есть после index | "*" не должно быть ничего, а непосредственно после range | "last" может идти только "rx" regexp

STR:

Expected result:

Actual result:

System information:
LeechCraft 0.6.70-1269-g487cee9
Built with Qt 4.8.5, running with Qt 4.8.5
Running on: Gentoo/Linux x86_64 3.16.3-gentoo #1 SMP PREEMPT Sun Oct 5 05:12:41 MSK 2014

#1

Updated by 0xd34df00d almost 6 years ago

  • Estimated time set to 4.00 h
  • Target version set to 0.6.75
  • Status changed from New to Assigned
#2

Updated by 0xd34df00d almost 6 years ago

  • Tracker changed from Bug to Feature

На самом деле это было by design.

#3

Updated by 0xd34df00d almost 6 years ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved
#4

Updated by Mellon almost 6 years ago

по опыту, опечатка - лишняя отработка. потому имхо не норм было

#5

Updated by 0xd34df00d almost 6 years ago

Энивей, исправлено.

#6

Updated by Mellon almost 6 years ago

  • Status changed from Resolved to Closed

Норм, пасяб.

Also available in: Atom PDF